Using IBM AIX Network Install Manager (NIM) to its fullest [2007]

Page 1

STG Technical Conferences

Using Network Install Manager (NIM) to its fullest Björn Rodén

http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

INTRODUCTION §

Björn Rodén

http://www.linkedin.com/in/roden Academic degrees –

BSc, DiplCSc, DiplSSc

Industry certifications – – –

IBM Certified Technical & Systems Expert (since early 90s) IBM, HP, SUN & Linux Certified Systems Administrator IBM & Tivoli Certified Specialist

Worked at – – –

IBM Sweden with AIX v2.2.1 and v3.1 IBM BP CBS UNIMAX in Sweden with AIX v3.2.5 until v4.3.3 and HACMP, TSM, SP/2 IBM BP PULSEN in Sweden with AIX v5L and HACMP, TSM, SP/2

Co-author of six (6) technical publications for IBM US: – – – – – –

2

NIM from A to Z in AIX 5L (2007), ISBN 0738486310 Linux Applications on pSeries (2003), ISBN 0738427950 Tivoli Storage Manager Version 5.1 Technical Guide (2002), ISBN 0738425192 AIX 5L Performance Tools Handbook (2001), ISBN 0738422983 RS/6000 SP System Performance Tuning Update (2001), ISBN 0738419281 IBM Director Best Practices (2006-2007), IBM XS-6009-R02

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

AGENDA 1. 2. 3. 4. 5. 6.

Basic principles of setting up a NIM Server. Managing AIX clients (LPAR). Establish an update strategy. Managing a Software repository using SUMA. Different ways to clone AIX systems. Using NIMHA with RSCT.

Hands-on: 1. Creating a NIM server. 2. Installing on a NIM client. 3. Manipulating the NIM client. 4. Installing a NIM client from scratch. 5. Configure NIMHA with RSCT.

3

objective

You will learn how to setup and use a NIM server to manage NIM clients

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

WORKSHOP material § §

This presentation, with hands-on instructions. The accompanying workshop text with more examples and how to’s, based on the “NIM from A to Z in AIX 5L” Redbook.

In addition: § The “NIM from A to Z in AIX 5L”, 2007, Redbook. § The other manual and documentation references on the “Related Documents” slide.

This workshop is a 1 hour compression of a 2-day NIM class and a +600 page Redbook. 4

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Let’s get started!

5

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Network Install Manager (quick version)

6

§

A NIM environment consists of at least one NIM server and at least one NIM client.

§

The NIM server has control over resources and their usage for network installation and configuration of NIM clients.

§

The NIM server allow other NIM servers or clients to be keepers of specific resources, these systems then become NIM resource servers.

§

The NIM server can work in push-mode where the NIM server initiates the actions to be performed on the NIM client, but also in a pull-mode, where the actions are initiated from the NIM client.

§

The NIM database structure is divided into four classes: Machines, Networks, Resources and Groups.

Primary reference: “NIM from A to Z in AIX 5L” Redbook. A special thanks to Chris Gibson, JeanMichel and of course the whole Redbook Team.

Operations are performed on NIM objects.

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Basic principles of setting up a NIM Server 1.

Decide the filesystem hierarchy for the NIM server storage: /tftpboot /export/lpp_source /export/spot /export/images

2.

Decide the naming convention for NIM objects: lpp<OS#><TL#> spot<OS#><TL#> net_<IP#NET>__<CIDR#>

3.

Create and mount the NIM server filesystems: 1.crfs 2.crfs 3.crfs 4.crfs

4.

=> lpp5306 => spot5206 => net_10_1_1__24

-v -v -v -v

jfs2 jfs2 jfs2 jfs2

-g -g -g -g

rootvg rootvg rootvg rootvg

-a -a -a -a

smitty storage smitty install smitty nimconfig

In the examples: lpar1 are the NIM server and lpar2 are the NIM client

size=64M -m /tftpboot -A yes -p rw -a logname=INLINE size=4G -m /export/lpp_source -A yes -p rw –a logname=INLINE size=1G -m /export/spot -A yes -p rw -a logname=INLINE size=6G -m /export/images -A yes -p rw –a logname=INLINE

Install the NIM server filesets: 1.bos.sysmgt.nim.master 2.bos.sysmgt.nim.spot

5.

Configure the NIM server basic setup: 1.nimconfig -a netname=master_net -a pif_name=en0 -a netboot_kernel=mp –a cable_type=N/A –a client_reg=yes 2.nim -o define -t lpp_source -a server=master -a location=/export/lpp_source/lpp5306 -a source=/mnt lpp5306 3.nim -o define -t spot -a server=master -a location=/export/spot –a source=lpp5306 -a installp_flags=-aQg spot5306 4.nim -o define -t standalone -a if1="master_net lpar2 0 ent0" lpar2

7

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Managing AIX clients (LPAR) 1.

Installing a NIM client from LPP_SOURCE (push):

smitty nim

1. Allocate resources: – nim -o allocate -a spot=spot5306 -a lpp_source=lpp5306 lpar2

2. Execute installation: – nim -o bos_inst -a source=rte -a installp_flags=agX –a accept_licenses=yes lpar2

2.

Installing a NIM client from SPOT (push): 1. Allocate resources:

Allocate, then execute.

– nim -o allocate -a spot=spot5306 -a lpp_source=lpp5306 lpar2

2. Execute installation: – nim -o bos_inst -a source=spot -a installp_flags=agX lpar2

3.

Running customizing scripts on the NIM client (push): 1. Create the script object and allocate it to the NIM client: – nim -o define -t script -a server=master -a location=/export/scripts/node_cust node_cust – nim -o allocate -a script=node_cust lpar2

2. Execute installation: – nim -o cust lpar2

4.

Create a NIM machine group resource: – nim -o define -t mac_group -a add_member=lpar2 lpar_group

8

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Managing AIX clients (LPAR) cont. 1.

Listing all available resources for the client (pull): – nimclient -l -L lpar2

2.

smitty nim

Allocating an lpp_source to the client (pull): – nimclient -o allocate -a lpp_source=lpp5306

3.

Deallocate previoiusly allocated resources for the client (pull): – nimclient -o deallocate -a lpp_source=lpp5306

4.

Performing an update_all (cust) operation from the client (pull):

If you allow the client to initiate operations!

– nimclient -o cust -a lpp_source=lpp5306 -a fixes=update_all

5.

Resetting the NIM client state (pull): – nimclient -Fo reset

6.

Deallocate a resource from the client (pull): – nimclient -o deallocate -a lpp_source=lpp5306

7.

Rebuild and recover a NIM client /etc/niminfo file (pull): – niminit -a master=lpar1

9

-a name=lpar2

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Establish an update strategy §

New AIX 5L OS Release and Service Strategy are implemented in 2007 for the AIX 5L Version 5.3 OS:

§ §

10

Starts with Technology Level (TL) 6 which is the first TL update to be supported for up to two years.

Based on the previous AIX 5L OS release strategy from 2006.

The Concluding Service Pack is no longer used.

Maintain the AIX 5L operating systems by installing Service Packs (SP), Program Temporary Fixes (PTF) or Interim Fixes for the entire support life of the TL.

AIX 5L OS support for new hardware is divided into two categories of support and exploitation.

Starting with TL6, Service Packs will be labeled with their release date, using the YYWW format, where YY is the 2-digit year and WW is the 2 digit week the SP is available.

The 2007 strategy require changes to the Version.Release.Modification.Fix (VRMF) encoding used for AIX 5L OS fileset levels, Starting with TL7, any filesets that are updated will get a new ‘M’ in the VRMF.

References: “IBM AIX 5L Operating System Release and Service Strategy Changes for 2007” by Jay Kruemcke, IBM AIX 5L OS Program Director and “IBM AIX 5L Operating System Service Strategy Details and Best Practices” by Julie Craft, AIX Development

# oslevel –s 5300-07-02-0811

Concurrent firmware (CFM) updates (nondisruptive concurrent or deferred). Disruptive firmware updates (all firmware releases).

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Establish an update strategy cont. §

Maintenance recommendations – Always create backups (mksysb) of your system before and after any update or upgrade. – If you are currently running with TL5, it is recommended to move TL6 or TL7. – When moving to a new TL, move to the latest SP first, that way you are guaranteed the TL will install. – You should move to a new TL: – – –

If your existing TL is out or is about to go out of service. You want to use new function and/or features in a new TL.. You will install on new hardware.

– You should move to a new SP: – –

Better safe than sorry --Plan to stay ahead --Don’t forget the firmware

You have problems and there is a fix for it. If you are currently running on a supported TL, then any SP will be supported, but the risk in staying at an older SP is being asked by IBM support to move up to a newer SP because it contains an update that you need.

– Update twice a year to a new SP or TL to stay current. – Periodically update the firmware on your System p servers, and sign up for the firmware subscription service.

11

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Managing a Software repository using SUMA §

The Service Update Management Assistant (SUMA) allows you to set up the capability of automating the download of maintenance fixes on a system: – – –

§

Install the bos.suma fileset. Use either the suma command or the SMIT suma fastpath. Use the NIM master for SUMA operations.

Download selected, filtered or all fixes from Support Fix Central Web site: –

Create a task which will send an email notification when a specific TL are available, checking once a month: –

suma –l

Unschedule defined SUMA tasks (in this case #1): –

suma –x –a RqType=ML –a RqName=5300-07 –a FilterML=5300-06 -a DLTarget='/export/lpp_source/5307‘

View defined SUMA tasks: –

suma –s “30 0 1 * *” –a Action=Preview –a RqType=ML –a RqName=5300-07 –a FilterML=5300-06 -a Repeats=y -a DLTarget='/export/lpp_suma/5307' –a NotifyEmail=”root@localhost”

Execute the download when the TL is available: –

suma –u 1

Delete a defined SUMA task (in this case #1): –

12

smitty suma

suma –d 1

SUMA use the following FixCentral FQDNs: § www7b.software.ibm.com § www14.software.ibm.com § www.ibm.com

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Different ways to clone AIX systems 1.

Backing up and cloning a system can be performed in all the same ways as any AIX server, with NIM the preferred choice is mksysb.

2.

Make sure that the receiving filesystem can store the mksysb image and that the ulimit is also set large enough (default 2GB).

3.

Determine the backup image storage space requirement using the size_preview option to the mksysb operation: –

4.

Use the NIM server to create and manage a NIM clients mksysb’s: –

5.

nim -o define -t mksysb -a source=lpar2 -a server=master -a location=/export/images/mksysb.lpar2 mksysb_lpar2

You can also use IBM Systems Director Virtualization Manager 1.2 with the NIM Agent to deploy mksysb to LPARS

The NIM alternate disk migration (nimadm) utility requires that the bos.alt_disk_install are installed on the NIM client, then you can use alt_disk_install from the NIM server: –

13

nim -o define -t mksysb -a server=master -a source=lpar2 -a size_preview=yes -a mk_image=yes -a mksysb_flags=-I -a location=/export/images/mksysb.lpar2 mksysb_lpar2

smitty nim

nimadm -j rootvg2 -c lpar2 -s spot5306 -l lpp5306

-d "hdisk1" -Y

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Using NIMHA 1.

Using NIMHA, the NIM db and filesystem objects can be synchronized between the NIM master and alternate_master.

2.

Using RSCT, the NIM alternate_master will detect when the NIM master stop and run the takeover script.

3.

Using SNMP, traps from the NIM alternate_master will notify that the failover has occurred.

All included with AIX!

14

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Using NIMHA cont. Normal Operation All NIM management and deployment operations are performed on the NIM master server. Using NIMHA to synchronize the NIM master db and resources to the NIM alternate_master server.

15

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Using NIMHA cont. Resume Operation from the alternate_master 1.

The NIM master goes offline.

2.

The NIM alternate_master RSCT detect that the NIM master is not online and starts the takeover process.

3.

The NIM alternate_master are now the master.

The NIM alternate_master can send SNMP traps to the SNMP manager for notification during the takeover process. 16

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences In the examples: lpar1 are the NIM server and lpar2 are the NIM client

Using NIMHA cont. 1. Configure the NIM alternate_master 1. Install the following filesets: § bos.sysmgt.nim.master and bos.sysmgt.nim.spot for NIM servers § rsct.core and rsct.basic for RSCT

2. Create the same filesystems on the NIM alternate_master. 3. Configure the NIM alternate_master: smitty nim_mkaltmstr

or §

niminit -a is_alternate=yes –a name=lpar2 –a pif_name=en0 –a master=lpar1 –a platform=chrp –a cable_type1=N/A

4. On the NIM master synchronize the database and the resources: §

nim -o sync -a force=yes -a replicate=yes lpar2 NOTE: Add the synchronization as a cron job (or similar).

17

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences In the examples: lpar1 are the NIM server and lpar2 are the NIM client

Using NIMHA cont. 2. Create a RSCT peer-domain cluster 1. Create the RSCT peer-domain definitions on the NIM master: preprpnode -V lpar1 lpar2

2. Create the RSCT peer-domain definitions on the NIM alternate_master: preprpnode -V lpar1 lpar2

3. Create the RSCT peer-domain cluster: mkrpdomain -V NIMCLUSTER lpar1 lpar2

4. Check the RSCT peer-domain cluster status: lsrpdomain

NOTE: We don’t start the RSCT peerdomain cluster just yet!

18

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences In the examples: lpar1 are the NIM server and lpar2 are the NIM client

Using NIMHA cont.

3. Configure RSCT condition-response event takeover script 1. Create the takeover script: /local/rpd/rpd.takeover § nim -o takeover $(lsnim -Z -t alternate_master|awk -F: '!/^#/{print $1;exit}')

2. Create the RSCT response definition: 1. mkresponse -n ACTIVATE -s /local/rpd/rpd.takeover TAKEOVER 2. lsresponse TAKEOVER

3. Create the RSCT condition to monitor: 1. mkcondition -mp -Sc -n "lpar2" -r IBM.PeerNode -e 'OpState <> 1' -E 'OpState == 1' MASTER_IS_DOWN 2. lscondition MASTER_IS_DOWN

4. Connect the condition with the response: 1. mkcondresp MASTER_IS_DOWN TAKEOVER 2. lscondresp MASTER_IS_DOWN 19

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

NOTE: We don’t start the RSCT RMC monitoring just yet! © 2007 IBM Corporation


STG Technical Conferences

Using NIMHA cont. 4. Activate RSCT condition-response event handling 1. Start the RSCT peer-domain cluster: startrpdomain -V NIMCLUSTER

2. Wait a minute for the peer-domain cluster to come “Online”: lsrpdomain -V NIMCLUSTER

3. Start the RSCT monitoring - on the NIM alternate_master: startcondresp MASTER_IS_DOWN

Now we are on-line!

RSCT are monitoring the NIM master from the alternate_master 20

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

RECOMMENDATIONS § Always use a NIM server to install and maintain AIX servers (works with 0.1CPU and 128MB memory, but if possible allow uncapped 1 VCPU and 512MB). § Allocate as much disk as possible, or use TSM Space Management to store rarely used file systems. § Use two NIM servers for everyday usage of NIM functionality (use NIMHA for synchronization and RSCT for failure detection).

21

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Related Documents § IBM AIX Manuals

– http://publib.boulder.ibm.com/infocenter/pseries/

§ IBM AIX Redbooks

– http://www.redbooks.ibm.com/ – NIM from A to Z in AIX 5L

§ IBM AIX Wiki

– http://wiki01.haw.ibm.com/collaboration/wiki/display/WikiPtype/Home

§ IBM Support Fix Central – – – –

http://www.ibm.com/eserver/support/fixes/ http://www14.software.ibm.com/webapp/set2/sas/f/best http://www14.software.ibm.com/webapp/set2/sas/f/hmc http://www.ibm.com/eserver/support/fixes/FixReleaseInfo.jsp?system=2&release=5.3

§ Google

– site:ibm.com – site:ibm.com – site:ibm.com

22

nim nimconfig nimclient

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

Using Network Install Manager (NIM) to its fullest

LET’S DO THIS!

23

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

WORKSHOP 1.

Log in to the Citrix MetaFrame Portal

2.

We have NIM servers (POWER6) and NIM clients on (POWER5)

3.

The root password for all LPARs are: ibmaix

4.

All AIX 5.3 LPPs you need are located in:

– –

24

Browse to https://egateway1.atlanta.ibm.com User id: 43588-16 Password: mqseries-54

Write your group name in the /etc/motd file on your two LPARs.

6.

Create a NIM server (the first LPAR):

7.

Work on the NIM client (the second LPAR): 1. 2. 3. 4. 5. 6. 7. 8. 9. 10.

IP-address 10.31.203.84-89 10.31.203.96-99

POWER5

10.31.201.124-129 10.31.201.134-139

/mnt (mounted from p570no4vlp1:/usr/sys/inst.images/installp/ppc)

5.

1. 2. 3. 4. 5.

Role POWER6

Create the filesystems (first lpp_source & spot). Install bos.sysmgt.nim.master and bos.sysmgt.nim.spot. Run the nimconfig command to configure the NIM master. Run the nim command to install filesets on the NIM client from the lpp_source. Download an SP using SUMA. Take over control of your NIM client from your NIM server. Check installed filesets on the NIM client. Install filesets using the lpp_source. Create an mksysb from the NIM client. Install filesets from the lpp_source. Install using the spot. Install using the mksysb. Create a script and run it with customize on the NIM client. Create a NIM alternate_master on the NIM client. Create a peer-domain and RSCT cluster between the NIM server and alternate_server

nim -o change -a new_master=lpar1 lpar2

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

WORKSHOP done.

That’s all there is to it!

25

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


STG Technical Conferences

THANK YOU for ATTENDING § Please fill in the evaluation questionnaire

A16 Björn Rodén http://www.linkedin.com/in/roden

26

System p, AIX and Linux Technical University –Amsterdam/2007 – Björn Rodén http://www.linkedin.com/in/roden

© 2007 IBM Corporation


Turn static files into dynamic content formats.

Create a flipbook
Issuu converts static files into: digital portfolios, online yearbooks, online catalogs, digital photo albums and more. Sign up and create your flipbook.